The collected works of ka0s - Page 2

When using Blender to render a scene with the newly compiled yafray it does seem to work.
The only thing I noticed was that when the scene uses an HDMI environment map it doesn't show up in the render.
In the Blender scene however the map is clearly present and shows in the world material preview pane.

This could also be due to new setting variables in blender of which I'm not aware of .... yet...

_________________
I can feel it, my mind is going ....
There's something wrong with Yafray ideed....
When I try to render the example cornell.blend I get the following error:
(This is not the complete output just the last few lines... )
Code:
Using a world resolution of 0.000892857 per unit
Rendering with 5 raydepth
4 anti-alias passes and 4 minimum samples per pass, 16 samples total.
Building bounding tree ... Object count= 4
OK
Light setup ...
Setting up lights ...
Yafray crashed
Could not execute yafray. Is it in path?


Is this because of the new compile of Yafray?

_________________
I can feel it, my mind is going ....
I found out today that when you disable xml output in the Yafray renderoption tab in blender, it does work!
That is, it will render the cornell.blend testfile and makes it look very good ( as usual) :)

I also discovered that when rendering the same scene on a Macbook ( intell inside... ) it looks very different from the one I've rendered using an Octane2.
In my scene there's a moving object made of glass, and on the SGI it looks really realistic, but on
my Macbook it looks like the glass has a foggy texture.

Can anyone do a test with a Yafray render using blender on SGI and another platform and confirm this?

So although my SGI takes a whole lot longer to render then my OS-X machine I still prefer it cause the final result looks so much better !

Thank you Charles for keeping Blender alive for us geeks :wink:

_________________
I can feel it, my mind is going ....
With version 2.44 I get more info in the command-line from yafray, why it's not using a background image.
Here's some of the output:
Code:
Rendering with 8 raydepth
4 anti-alias passes and 4 minimum samples per pass, 16 samples total.
[Warning]: Background world_background does not exist
Building bounding tree ... Object count= 15
OK

Somehow it no longer seems to support HDRI images as a background .... !
The same scene worked just fine with version 2.42 ...... :shock:
Can someone confirm this ?

_________________
I can feel it, my mind is going ....
nekonoko wrote:
The library problem is solved but I'm getting a crash when trying a test render of the 'big.xml' file dexter1 posted a while back:

Code:
[email protected] ~ % yafray big.xml
Starting YafRay ...
Loading grammar ...
Starting parser ...
Parsing OK

Loading plugins from '/usr/nekoware/lib/yafray'...
Registered arealight
Registered basicblocks
Registered basicshaders
Registered blendershaders
Registered globalphotonlight
Registered HDRI background
Registered hemilight
Registered mix block
Registered pathlight
Registered photonlight
Registered pointlight
Registered Shader Background
Registered softlight
Registered spherelight
Registered spotlight
Registered sss
Registered sunlight
Registered sunsky
found 18 plugins!
[Loader]: Added shader MAMaterial
[Loader]: Added shader MAcristal
[Loader]: Added shader MArojo
starting build of kd-tree

=== kd-tree stats (0.22s) ===
primitives in tree: 3328
interior nodes: 9111 / leaf nodes: 9112 (empty: 4397 = 48.255%)
[Loader]: Added object OBCube.001
starting build of kd-tree

=== kd-tree stats (0s) ===
primitives in tree: 12
interior nodes: 22 / leaf nodes: 23 (empty: 9 = 39.1304%)
[Loader]: Added object OBCube.002
starting build of kd-tree

=== kd-tree stats (0s) ===
primitives in tree: 12
interior nodes: 25 / leaf nodes: 26 (empty: 10 = 38.4615%)
[Loader]: Added object OBCube.003
starting build of kd-tree

=== kd-tree stats (0s) ===
primitives in tree: 2
interior nodes: 1 / leaf nodes: 2 (empty: 1 = 50%)
[Loader]: Added object OBPlane
starting build of kd-tree

=== kd-tree stats (0s) ===
primitives in tree: 12
interior nodes: 1 / leaf nodes: 2 (empty: 1 = 50%)
[Loader]: Added object OBCube
[Loader]: Added photonlight light LAMP1
[Loader]: Added sunlight light LAMP2
[Loader]: Added pathlight light path_LT
[Loader]: Added constant background world_background
[Loader]: Added camera MAINCAM
Using a world resolution of 0.00142857 per unit
Rendering with 5 raydepth
2 anti-alias passes and 4 minimum samples per pass, 8 samples total.
Building bounding tree ... Object count= 5
OK
Light setup ...
Setting up lights ...
Shooting photons ... OK
Emitted 250000 Stored 170253 search 100
Pre-Gathering (49915) ... Assertion failed in file "../../libC/lang_support/unwind.cxx", line 579
zsh: IOT instruction (core dumped)  yafray big.xml


The binary is stripped so I wasn't able to get a dbx dump.


I tried this on my Octane2 with Irix 6.5.22 and I didn't have any problems rendering this.
Here's the final render :


Attachment:
big.jpg
big.jpg [ 61.93 KiB | Viewed 526 times ]


And in order to try to keep this software alive for the Irix platform can anyon else give this render a try?

_________________
I can feel it, my mind is going ....
Looks promising !
But so far not a single message in the forums ...... :|
I can feel it, my mind is going ....
I've downloaded the latest version of the fabulous djv player and when I
tried it on a bunch of targa's I get the folowing Error:

Code: Select all

ERROR OpenGL Maximum Texture Size: 512
ERROR OpenGL Maximum Texture Size: 512


Does this mean my Octane 2 V10 Isn't qualified anymore ?

Also after I start the program on the commandline I get the following message on the same line :

Code: Select all

[email protected]: /usr2/images %  djv_view
[codecinfo] Error: 5


What could this mean ?
I can feel it, my mind is going ....
That would be great I was anciously awaiting the OpenGL SPeedboost...... :cry:

_________________
I can feel it, my mind is going ....
Thanks for the update Darby.

Here's some feedback on version 0.71.
It now works on my Octane2 with V10 Graphics.
Although when executing on the timeline I still get this error :
Code:
[codecinfo] Error:


The downside of this update is that it cannot display a tga sequence ( 1024x576 ) in realtime.
of the 25 fps it can only handle 12 -14 fps. The 720x576 tga sequence plays almost 18-22 fps.
Now I know that this is not a hardware problem since I can play this in realtime with
Blender. ( the software I made the tga animation with )

The resizing of anamorph material ( 720x576 ) to 16x9 ( 1024x576 ) is much better.
There's no decrease in speed anymore ( means that this resizing is done in realtime ) !

I tried to use the cache option and increased it to 512 MB but this didn't seem to make any
difference, still can't play 25 fps.
( this was tested on 720x576 and 1024x576 tga sequences. NON SCALED )

I really hope you succeed in optimizing this code for the SGI cause I really like it ;)

_________________
I can feel it, my mind is going ....
Thanks Charles,

Looking forward to the new 2.45 release.
And many thanks for your effort in keeping this juwel available for us IRIX geeks ;)

Cheers,
Bob

_________________
I can feel it, my mind is going ....
dj wrote:
ka0s wrote:
Although when executing on the timeline I still get this error :
Code:
[codecinfo] Error:


That's the QuickTime library I'm using; I still need to see if there's an option to turn that off.

O.K. that must be easy compared to the optimizing stuff ... ;)
dj wrote:
ka0s wrote:
The downside of this update is that it cannot display a tga sequence ( 1024x576 ) in realtime.
of the 25 fps it can only handle 12 -14 fps. The 720x576 tga sequence plays almost 18-22 fps.
Now I know that this is not a hardware problem since I can play this in realtime with
Blender. ( the software I made the tga animation with )


Are the tga files compressed? Also, do you know if blender caches them in memory or plays them directly from disk?


As far as I can tell does Blender play the compressed tga's realtime from disk.
When pressing play it play's the files realtime in one go, usually when playing from RAM the first run will be dropping frames.

dj wrote:
ka0s wrote:
I tried to use the cache option and increased it to 512 MB but this didn't seem to make any difference, still can't play 25 fps.


That's my bad; the cache feature is completely broken in 0.7.1. I have a 0.7.2 prerelease package that fixes this; I'll try and put a tardist together.


I see, looking forward to the tardist update !
dj wrote:
ka0s wrote:
I really hope you succeed in optimizing this code for the SGI cause I really like it ;)


Thanks! As long as you can help me with feedback I'll be motivated to keep the IRIX port going. :)


No thank you, for your effort in keeping the SGI platform alive !!!

_________________
I can feel it, my mind is going ....
Hi Darby,

Have been extremely busy but I finally found the time to try your latest release.

I tried the 0.7.2 version and its great !!!!
It plays back compressed targa sequences in real time ( 720 x 576 - 25 fps ) even when scaled up to 16x9 .... !)

This is better then the performance I get with Blender or even shake ........

Your the Man !
I can feel it, my mind is going ....
Hi Darby,

I played the targa sequences from the optiondrive in my Octane2 / 6.5.22 here's a hinv:

Code: Select all

1 400 MHZ IP30 Processor
CPU: MIPS R12000 Processor Chip Revision: 3.5
FPU: MIPS R12010 Floating Point Chip Revision: 0.0
Main memory size: 1536 Mbytes
Xbow ASIC: Revision 1.4
Instruction cache size: 32 Kbytes
Data cache size: 32 Kbytes
Secondary unified instruction/data cache size: 2 Mbytes
Integral SCSI controller 0: Version QL1040B (rev. 2), single ended
Disk drive: unit 1 on SCSI controller 0
Disk drive: unit 2 on SCSI controller 0
Disk drive: unit 3 on SCSI controller 0
Integral SCSI controller 1: Version QL1040B (rev. 2), single ended
IOC3/IOC4 serial port: tty1
IOC3/IOC4 serial port: tty2
IOC3 parallel port: plp1
Graphics board: V10
Integral Fast Ethernet: ef0, version 1, pci 2
Iris Audio Processor: version RAD revision 12.0, number 1


There's some dropping frames when loading the targa's into RAM,
but after that it's a breez !)

I've rendered the targa's with Blender in 720x576 4x3 and Anamorph 16x9.
And I did some renders in 1024X576.

I only use targa's because in my experience they cause the least problems when
importing into other software on other platforms or systems.

At work we also use OS-X more and more because of it's stability compared with WinBlows.
So an OS-X version would be very Nice !

Cheers,
Bob

If you need more info on performance issues let me know.
I can feel it, my mind is going ....
markwend wrote: Hey - let me chime in and say that I think that the djv suite is really a really useful tool. I've worked for a long time in professional film graphics, and this is by far the most useful and professional playback tool I've found in the public domain.


Here here !!!!

markwend wrote: One request: I write a lot of imaging code and rerender to the same output file. I display an image in djv_view, and then hit 'reload' whenever I rewrite the image. It would be GREAT if you kept the previous image in a temporary buffer, and have a 'toggle previous/current' key so that you can see what the change was. Right now, 'reload image' just reloads, but you can't see what the previous image was any more. With the toggle, you can go back and forth to really study any subtle changes that happen to the image.


This would be nice to check two renders for anomalies ..... !)
I can feel it, my mind is going ....
Hi Darby,

Still think this piece of code is awesome in terms of usability,
could you post a link for the latest version ?

Cheers,
Bob
I can feel it, my mind is going ....
Maya and Shake definitely rule this side of the Universe.
I use Shake and Maya on a SGI quite often and althuogh these machines are concidered
to be slow compared to todays standards I still love the responsiveness of my SGI !
Where Pyrana is concerned its just like shake but with a somewhat simpeler UI.
I can feel it, my mind is going ....
There are a whole lot of different ways to export image file sequences with ffmpeg using memcoder.
The only downside is that it is a commandline app and the commands tend to become astronimical.

But in short Yes it can be done on a SGI with a healthy dose of persiverence 8-)

Look at the man for memcoder or ffmpeg.

Cheers,
Bob

_________________
I can feel it, my mind is going ....
A mac these days is serious UNIX !
I rest my case ...... :!:
I can feel it, my mind is going ....
As a postproduction house we decided to use blender for most of our 3D work.
Since it can be installed on every machine we have ( 30+ ) without having to worry
about licences.
And through the effort of the opensource community the features and quality increases by the day....

In my humble opinion I believe the day will come that it will outrun Maya economically speaking :!:
I can feel it, my mind is going ....
But do I understand correctly that the ( supposedly workable ) version 14 of AC was never released for Irix :?:
And was AutoCad the only Architectural drawing software available for Irix :?:
I can feel it, my mind is going ....
I hate to break up your party but this great forum link is dead ....... :?
I can feel it, my mind is going ....
Can anyone confirm that the 2.44 version runs 11% faster on a SGI then the 2.45 version.
And does anyone have a clue why this is?
I can feel it, my mind is going ....
I have just got my hands on a DVD ROM drive and have hooked it up to my Octane2.
But when I try to mount or acces a CD or DVD nothing happens.

I did try to use XCDRoast to see if it would detect a drive and yes it does!
Here's what it reports :

Code: Select all

scsidev: '1,4,0'
scsibus: 1 target: 4 lun: 0
Write Performance:
START LBA:         0
End LBA:     1153595
Start Perf:     2822 == 16x CD
END Perf:       7056 == 40x CD

Read Performance:
START LBA:         0
End LBA:           0
Start Perf:        0 == 0x CD
END Perf:          0 == 0x CD

End LBA:        2822
Read Speed:  1153595 == 6554x CD
Write Speed:    7056 == 40x CD

Cdrecord-ProDVD-ProBD-Clone 2.01.01a35 (mips-sgi-irix6.5) Copyright (C) 1995-2007 Jörg Schilling
Using libscg version 'schily-0.9'.
Device type    : Removable CD-ROM
Version        : 2
Response Format: 2
Capabilities   : SYNC LINKED
Vendor_info    : 'TOSHIBA '
Identifikation : 'DVD-ROM SD-M1401'
Revision       : '1007'
Device seems to be: Generic mmc2 DVD-ROM.

Drive capabilities, per MMC-2 page 2A:

Does read CD-R media
Does not write CD-R media
Does read CD-RW media
Does not write CD-RW media
Does read DVD-ROM media
Does read DVD-R media
Does not write DVD-R media
Does not read DVD-RAM media
Does not write DVD-RAM media
Does not support test writing

Does read Mode 2 Form 1 blocks
Does read Mode 2 Form 2 blocks
Does read digital audio blocks
Does restart non-streamed digital audio reads accurately
Does not support Buffer-Underrun-Free recording
Does read multi-session CDs
Does read fixed-packet CD media using Method 2
Does not read CD bar code
Does read R-W subcode information
Does not return R-W subcode de-interleaved and error-corrected
Does read raw P-W subcode data from lead in
Does return CD media catalog number
Does return CD ISRC information
Does support C2 error pointers
Does not deliver composite A/V data

Does play audio CDs
Number of volume control levels: 16
Does support individual volume control setting for each channel
Does support independent mute setting for each channel
Does not support digital output on port 1
Does not support digital output on port 2

Loading mechanism type: tray
Does support ejection of CD via START/STOP command
Does not lock media on power up via prevent jumper
Does allow media to be locked in the drive via PREVENT/ALLOW command
Is not currently in a media-locked state
Does not support changing side of disk
Does not have load-empty-slot-in-changer feature
Does not support Individual Disk Present feature

Maximum read  speed:  7056 kB/s (CD  40x, DVD  5x, BD  1x)
Current read  speed:  7056 kB/s (CD  40x, DVD  5x, BD  1x)
Maximum write speed:     0 kB/s (CD   0x, DVD  0x, BD  0x)
Current write speed:     0 kB/s (CD   0x, DVD  0x, BD  0x)
Buffer size in KB: 128
Copy management revision supported: 1

Current performance according to MMC get performance:

Maximum performance according to MMC get performance:

Supported profiles according to MMC-4 feature list:
Current: CD-ROM
Profile: DVD-ROM
Profile: CD-ROM (current)

Supported features according to MMC-4 feature list:
Feature: 'Profile List' (current) (persistent)
Feature: 'Core' (current) (persistent)
Feature: 'Morphing' (current) (persistent)
Feature: 'Removable Medium' (current) (persistent)
Feature: 'Random Readable' (current)
Feature: 'Multi Read' (current) (persistent)
Feature: 'CD Read' (current)
Feature: 'DVD Read'
Feature: 'Power Management' (current) (persistent)
Feature: 'CD Audio analog play'
Feature: 'Time-out' (current) (persistent)
Feature: 'DVD-CSS'
Feature: 'Real Time Streaming' (current)


So there must be something I'm not getting into my thick head.... :?
I do not need to install something from my Irix software, or do I ?
I can feel it, my mind is going ....
Hakimoto wrote: Beautiful cards. I can wholeheartedly recommend them. Never had any issues with mine.


Hi Hakimoto,

What kind of speakersystem did you hook up to the Revolution 7.1?
And didn't you live in Brussels not to long ago ?

Cheers,
Bob
I can feel it, my mind is going ....
I'm very sure that both versions where compiled using MIPSPRO.
And yes 11% faster when rendering .
I can feel it, my mind is going ....
I would very much like to contribute in any way possible...
I can feel it, my mind is going ....
Hi There,

I don't know if you might be interested, but I'm selling almost everything concerning my SGI collection
due to the lack of space and time.
Except for 1 octane2/V10/400R12k. ( This one I keep around and will try to max-out )

This would mean the following items are for sale :
PI 4D35 ELAN Graphics 128MB RAM 9GB-HD / Internal TAR and CD Drive.
Indigo ELAN MAX-CPU / MAX RAM
Indy MAX
Indigo2 Extreme 256MB RAM
Indigo2 Maximum Impact also MAX-CPU MAX-RAM + Mpegcompression optionboard
Octane2V10 400R12k 1.5GB-RAM fastSCSI-PCICard/AutodeskFlame installed - 4x34GB RAID
FuelV10 600R14k 1.5GB-RAM firewirePCI + Illiama flatpanel
All the systems come with keyboard mouse and monitor and a whole lot of installer CD's and Book's.

The whole lot for 1500 EURO's and if Holland is to far for such a load of stuff to be shipped
we'll work something out.
Let me know if you are interested by e-mail [email protected]

Cheers,
Bob
I can feel it, my mind is going ....
Hi there,

It's been a while but then I've been very busy trying to run a postproduction company in Hilversum and Amsterdam (The Netherlands)

But in this case I've put the default Blender startup in .sgidefaults as blender -w -d &

Try this and who knows the -d will give you more info in the shell.

Cheers,
Bob
I can feel it, my mind is going ....
Funny thing is that when trying to play-back a render of 300 frames the play-back stops at 65 frames and loops right back to frame 1 ..... :?

Can anyone confirm this ?

Is there a playback limit introduced in this version ( previous version 2.44 plays just fine ... )
I can feel it, my mind is going ....
Am I doing something wrong or is there no way I can get my hands on Blender-2.48 for IRIX ....... ?????
Seems like the author and the website are gone .......


Can anyone help me to get to the binary ?

Cheers,
Bob
I can feel it, my mind is going ....
Tried it and it crashes with segmentation fault on blend file using yafray. Does this have something to do with Python cause I still have 2.4.1 or
is it the B.blend file?
I can feel it, my mind is going ....