SGI: Computer Graphics

Softimage|3D behaving badly


I'm running an Indigo2 MAX Impact with IRIX 6.5.10 and 512mb ram. System works fine, Maya 3 runs fine. I installed Soft3D 3.8.2 yesterday, and here are the issues:

1 - Starting the program from the Toolchest, it loads up but most of the interface doesn't draw. There's just the time slider - no buttons to click. Have to kill the process to exit.

2 - Running "soft" from the command line, I get an error about "" According to the manual, this has something to do with the IRIX Digital Media Extension, which probably wasn't installed when I bought this I2 from eBay.

So, I just dumped $150 on a full IRIX 6.5 set on eBay, hoping that installing the DME will solve this problem. Am I barking up the right tree here?


the startup scripts of si3d are crap (also xsi).
meanwhile it seems like avid is just a wintel company and you'll feel this everywhere :twisted:

however, search for the libs and link them to some known place like /lib32 or whatever.
of course you can also include all relevant folders in your LD_LIBRARYN32_PATH etc.

it will continue to crash from time to time as long as you didn't get all libs used...

remember that SI|3D has been an M$ app for a while.. ;-)

Stupid move of them to sell that. The best aplication they got... and they sell it. HAH! Sucks to be M$ :-)

Shall I describe it to you? Or do you want me to get you a box?
I bought 3D v4.0 for my Octane. Had to extensively modify the config-files in the /softimage durectory since most of them were still refering to v3.9.2.2 - a real travesty. Once you get it up and running it is a nice piece of software, though - with a horrible interface (which is, luckily enough, customizable).
3.8 SP2 was way before softimage went all wintel (1998). i ran the same version once on similar configuration - not having any problem with it. are you running with some weird screen resolution? soft is restricted to - as far as i remember - 1024, 1280 and 1600 resolutions.

other than that your soft installation/irix installation/libsearchpath might be a bit screwed.

afaik, soft never went, what people here like to refer to as wintel crap. it runs way better on IRIX than on windows - except for rendering performance on your average desktop system of course.

assyrix: does 4.0 feature motion capture data export of some sort (biovision, acclaim)?
yeah si3d is better on irix. i rather thought of xsi :D
si3d is great at all and still used!

Turns out that the "" error was occuring because I was running "soft" from the command line without specifying any arguments. When I run Softimage from the Toolchest, the only complaint is it can't find databasedir.rsrc, which really shouldn't cause the crash problems I'm seeing.

Strange. I can scrub the time slider, which makes the viewports draw. But I can't manipulate any of the views, and there are no other buttons to push.

The Particle program runs fine, as does the Dialog Editor. This is so annoying!

GIJoe wrote:
assyrix: does 4.0 feature motion capture data export of some sort (biovision, acclaim)?

Not that I am aware of. They have also removed the particle generator and replaced it with a 3rd party tool.

SI|3D has the best user interface I've ever seen in any program. I love it extremely.

Shall I describe it to you? Or do you want me to get you a box?
Whiter, I totally agree with you. The interface of SoftImage is VERY good, I was shocked to read the post by assyrix ;)
XSI's GUI is not that good, but I think the software has some very neat options... unfortunately it runs pretty bad on IRIX and looks totally wrong :) No wonder why they dropped it for IRIX.
soft's UI is definitely different, thats for sure ;)
i absolutely hated it for tasks like modelling - but for animation it was really nice after a while. definitely more convenient and clean than having to shuffle several floating windows around the screen in order to keep track of things.

btw. i do not remember the UI to be very customizeable. all you could do was assign supra keys and change the color scheme somewhat. for more control you had to hack some rsrc files somewhere in the soft directory.
did they change it for the better in 4.0?
Finally got it working this weekend - turns out it was just a license issue. So now I've got v3.9.2 up and running, no OS changes required.

Man, it's great - loads up in about 5 seconds, compared to Maya 3 which takes about a minute. It also uses only 14mb ram at startup, whereas Maya 3 uses close to 60mb. I do miss the days before OOP/Java/crap bloatware.

As far as the old interface goes, I like it. It doesn't call attention to itself - lets you focus on the viewports. Seems like XSI's was over-compensation for 3D's "archaic" look, hence the fancy rounded buttons with beveled edges and shading. Overkill.

I like text buttons - you can immediately read their function. Soft|3D, Lightwave, and just a few other packages had that advantage. A far cry from 3dsmax, which is basically layers upon layers of cryptic icons.

Anyway, time to go render some dinosaurs...

Interesting thread. I'm curious, what version(s) of Maya and Softimage|3D do you folks consider to be "the best" for Indigo2 MaxImpact and any O2 in general?

Is SI|3D still sold and does the most recent version of it still run well on older SGIs?

How does one go about buying an older version of Maya?
as for maya, i would not recommend any newer version for the configurations you mentioned. maybe 2.x? the scripted interface alone is pretty cpu intensive and therefore unresponsive if you're dealing with it for a while. on octane2, it's very useable and suited for daily work - the CPU makes the big difference - maybe if you have an o2 with R12k, it could make sense.

soft3d, well 3.8 SP2 runs pretty good at max impact, they switched the interface-look somewhat in 3.9 and newer versions - never seen that running on an SGI though and so don't know if it makes a difference in performance. bear in mind that soft3d is pretty good at animation and might do a good job at rendering, too - but the whole modeling/dynamics/particles/weighting-stuff is pretty outdated by todays standards.
afaik, you cannot get older releases - they are trying hard to convince you to make the move to XSI anyway ;)
On my I2 Max Impact, Maya 3.01 is slow. Takes forever to load and yes, the interface does bog down the program. The 3D views draw quickly, but just opening the attribute editor or hypergraph takes a second or two. I have no experience with other versions on this machine, but I wouldn't attempt to run anything newer.

Soft 3.9 seems to run just as well as 3.8 - the interface updates were only made on the wintel side. It works absolutely great - the interface is snappy and it renders fast. Lots of fun to use on a Max Impact, and would probably work very well on R5K machines as well. (If you're using the wintel version, you can revert to the old interface by adding "set SI_OLD_UI=1" to your environment file.)

The current version of Soft|3D is 4.0, which I haven't used or heard much about.

Regarding where to get the program, eBay is a good bet. You can often pick up a complete set of Soft|3D 3.X for less than $50.