Getting Started, Documentation, Tips & Tricks

Making a bootable IRIX DVD

Let's face it, we all hate digging through the box(es) of CDs and irix updates, patches, etc. every time you need to install or add to the system. Seeing as the SCSI Toshiba 1711 DVD rom seems to work fine with IRIX, I have to ask.... Has anyone sucessfully made a bootable IRIX dvd? Am I asking for the impossible here?
Thanks Andreas,

Have you tried it? I was under the impression from other threads on comp.sys.sgi that it would be fairly complicated.... this seems too easy! I have a feeling it won't be, but at least the night is still young!
no, I haven't tried, I usually do it via network install ;)
I can only see two possible reasons why this could fail: (1) DVD-Roms may not allow 512 byte sectors off DVDs (or require special instructions to be sent to do so) and (2) what's the size limit of EFS anyway? I don't think either of them are going to get in the way, but lacking DVD drives or recorders, I won't be able to try in the near future. If you are going to test this, try making a bootable CD-R first, and when that works, record the very same image to a DVD(+-)RW and try booting that.
canavan wrote: (2) what's the size limit of EFS anyway?


8 Gb, so this will fit nicely on a double layer DVD
Hmm... so far, preliminary tests aren't good. I just burned a straight UDF DVD with the 6.5.23 updates on it (not bootable). SWManager returns the following:

ERROR: Cannot mount local CD :

I have been able to boot with real IRIX CD's on this drive. Could be the 512 byte sectors issue. My optimism is fading :(
hello,

why not
1. burning the inst. tools the normal way
2. burning the rest on 1 iso dvd (dvds don't have to be udf)
3. install the stuff ;-)
r-a-c.de
Perhaps that's the problem.... I'm burning on a mac with toast. Won't allow ISO formated dvd's. Nor will it allow ISO CD's greater than 800 megs. Perhaps I'll try on a PC with GEAR Pro. Unles someone has another suggestion.

On another note.: When I went to eject the DVD I got the following:

dksc0d4vol: [Alert] Illegal request: Invalid command code (asc=0x20, asq=0x0) CDB: 2a 0 0 0 0 40 0 0 1 0

Since installing the drive, I haven't tried to many DVDs in it. CD's all seem to work fine.
try to do it with cdrecord. Ain't there a fink package for it?
[email protected] wrote: try to do it with cdrecord. Ain't there a fink package for it?


http://fink.sourceforge.net/pdb/package.php/cdrecord
Twitter: @neko_no_ko
IRIX Release 4.0.5 IP12 Version 06151813 System V
Copyright 1987-1992 Silicon Graphics, Inc.
All Rights Reserved.
zafunk wrote: Perhaps that's the problem.... I'm burning on a mac with toast.

Use hdiutil, it should already be installed (assuming you're using OS X).

Code: Select all

PowerBook$  hdiutil makehybrid -o myimage.iso StuffForImage/ -iso
PowerBook$  hdiutil burn myimage.iso

Read the hdiutil manpage, it can do just about anything.
I had an error like this with my Plextor Burner. I switched on parity and it went away. Cheers.
Patrick

- That's what she said -
Well, it looks as if all my tests were failures. None of my test disks would mount, let alone boot. I've made successful CD's using mkefs but, IRIX sems to recognize the DVD's as DVD's. I can't access any of th data on the disk.

Anyone else had any luck?
Have you tried burning the exact same image you have used successfully for a CD on a DVD? If so, and you can't even mount that DVD with irix running normally (i.e. not miniroot), then I strongly suspect a problem with sector size as someone mentioned on comp.sys.sgi.*. What kind of drive are you using on your SGI? Something official, a Toshiba? Or a recorder with ACARD?