Sun patches... SOL w/Oracle?

I've recently come to own a Sun Unified Storage 7410 setup. It appears to be a standard Sun branded 2U AMD Opteron server strapped to a J4440 disk array (24 disks). It looks like there's 20x 1TB mechanical disk drives and two unknown units that look more like SSDs then anything.

I've booted up the machine and it appears to run some sort of embedded version of OpenSolaris that has a nifty web GUI on it. I can login to the machine via my web browser and configure everything, but the software empowering it is quite old (2010). I see that Oracle still supports these machines and they've apparently released quite a few versions of the OS since then, but naturally I need a support contract to download anything.

I'm pretty sure I already know the answer to this question, but am I screwed? I know there was a huge paradigm shift many years ago where everyone collectively decided to lockup their patches (I still remember a day and age where SunSolve was free and you could get anything you wanted from Sun without trouble). I'm guessing that there's probably no way to get Oracle patches without one of their support contracts, but I just wanted to check first to be sure. If I can't get access to the software then I'll probably just dump the entire setup on eBay and buy something more SOHO friendly instead.

I've got butterfingers!
if that's gonna be a soho unit then, is something broken or some required functionality missing?
i mean do you actually need updates, patches and stuff?
I'd be lying if I said I wasn't struggling to find a use for this thing. It's big, it's heavy, it's loud, and it sucks up a fair amount of power. My primary attraction to it was the iSCSI target abilities, since I wanted to mess around with netbooting various clients around the house via iPXE (sanboot). I've been told that they've made many improvements to this (and the system as a whole) over the years, and that the more recent versions of the software are a definitive improvement over the old.

That's about all I know. The system didn't cost me anything more then a 6 hour trip each way (about $40 in gas), so I'm not inclined to invest any money in an Oracle support contract. I'm very tempted to sell it for a few thousand bucks, but I've heard good things about these systems in the past (specifically the software stack), and since I love twiddling around with stuff I was kinda hoping to give it a go and see what it's like.

So I suppose the answer to your question is "I have no idea". The only thing I know for sure is that I keep reading about how much more awesome the new software is over the old. Maybe that's just Oracle marketing PR (it seems like a few of the Fishworks guys left after the whole Sun takeover thing), maybe not. I have no idea unless I can get my hands on the patches to try it out.

I've got butterfingers!
Dennis Nedry wrote: I wanted to mess around with netbooting various clients around the house via iPXE (sanboot)

well then just do that. otherwise you won't know if you're actually missing something
I spent the majority of the evening messing around with the system. It seems fairly impressive when it works, but otherwise glitchy as hell. I couldn't maintain an iSCSI connection for more then 4 hours and CIFS sharing seems broken in more ways then one. I love the web GUI, but it doesn't seem like a very reliable appliance at the moment.

I've tried asking about this elsewhere on the internet and the response is just "yeah, that's because you're running ancient software, you should upgrade". Hence my original post- I think this machine is running one of the first, if not *the* first release of the Fishworks. There's been at least four major patches since then (2010.Q3.2.1, 2010.Q3.4.2, 2011.1.4.2, and 2011.1.9.2) that need to be applied in order.

So again, what can I do (if anything)?

I've got butterfingers!
Dennis Nedry wrote: what can I do (if anything)?

either get the patches and hope it helps or sell it or use it as it is or don't sell it but don't use it and put it in the closet :P
Okay, do how do I get the patches?

Trying to download them from Oracle just results in an error message that says "You do not have the required access privilege to download this patch". Apparently I need to register at some MyOracle Support site, but that wants a support identifier and I quote:

Support Identifiers are the "contract" between your organization and Oracle. They define the privileges you have to file service requests, download patches and more. These privileges are approved and set by an administrator in your organization. You need at least one support identifier in your account to get to most features.

I obviously do not have one of these. What am I supposed to do? That was the whole point of my original post. I would get the patches if I could, but apparently I can't, unless there's some other way to get them that I haven't thought of (and yes, I've tried googling the hell out of them- the file names, release dates, everything- there's a few scattered around but not the right versions I need for the sequential update path).

I've got butterfingers!
Dennis Nedry wrote: That was the whole point of my original post. I would get the patches if I could, but apparently I can't, unless there's some other way to get them that I haven't thought of

that's how it is and i'm afraid discussing "alternative" ways of getting these patches or anything else that requires a valid support contract is against our forum rules.