SGI: Video

mplayer optimal movie resolution for Octane MXE

I am interested in what other Octane MXE owners deem is the most optimal movie size for gl2 playback using mplayer. I can't seem to get mplayer to playback with gl2 on large movies, and am guessing it's lack of tram? (Octane has 8MB?)

Below are my result so far

720x480 X11 - OK
720x480 gl2 - Not OK (not enough tram?)
576x324 gl2 - OK, quality low when full screen zoomed

Also, I don't seem to have man pages for mplayer, how do I install it?

TIA
barefoot
with what cpu?

i have an r12k 300mhz and i am about to get an MXI. i was kinda hoping mplayer would be ok under that setup.
ubi dubium ibi libertas
NauSeuM wrote: with what cpu?

i have an r12k 300mhz and i am about to get an MXI. i was kinda hoping mplayer would be ok under that setup.


Dual R12k 300Mhz, if it's any consolation, the Octane audio is amazing! (using mplayer of course)
I'm confused what issues I had...

I used to watch movies fullscreen just fine on my octane with just SI+Tram. What mplayer command line are you using?

If I recall I used either gl or gl2 for the video out...command line was something like

mplayer -vo gl -ao sgi -zoom -f moviename
However, for 720x480, it would need a texture sized at 1024x512, which at 32bpp would end up being 2mb, and that should fit. I know that gl2 uses multiple textures, try the standard gl plugin and see if that runs better?
vegac wrote: I'm confused what issues I had...

I used to watch movies fullscreen just fine on my octane with just SI+Tram. What mplayer command line are you using?

If I recall I used either gl or gl2 for the video out...command line was something like

mplayer -vo gl -ao sgi -zoom -f moviename
However, for 720x480, it would need a texture sized at 1024x512, which at 32bpp would end up being 2mb, and that should fit. I know that gl2 uses multiple textures, try the standard gl plugin and see if that runs better?


I was using:
mplayer -vo -gl2 -vf format=RGB24 name.avi whiich does not work with 720x480 movies.

With:
mplayer -vo gl -ao sgi -zoom -f name.avi
I get errot:
MPlayer 1.0pre4 - MIPSpro Compilers: Version 7.41 (C) 2000-2004 MPlayer Team

CPU: SGI MIPS
Reading config file /opt/mplayer/etc/mplayer/mplayer.conf
Reading config file //.mplayer/config
Unknown option on the command line: f

With:
mplayer -vo gl -ao sgi -zoom name.avi
I get a blank window and error:
MPlayer 1.0pre4 - MIPSpro Compilers: Version 7.41 (C) 2000-2004 MPlayer Team

CPU: SGI MIPS
Reading config file /opt/mplayer/etc/mplayer/mplayer.conf
Reading config file //.mplayer/config
Unknown option on the command line: f
[email protected]:/usr/people/paul/movies> mplayer -vo gl -ao sgi -zoom name.avi
MPlayer 1.0pre4 - MIPSpro Compilers: Version 7.41 (C) 2000-2004 MPlayer Team

CPU: SGI MIPS
Reading config file /opt/mplayer/etc/mplayer/mplayer.conf
Reading config file //.mplayer/config
Reading //.mplayer/codecs.conf: 66 audio & 176 video codecs
font: can't open file: //.mplayer/font/font.desc
Font /opt/mplayer/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using usleep() timing
Can't open input config file //.mplayer/input.conf: No such file or directory
Can't open input config file /opt/mplayer/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config

Playing name.avi.
Cache fill: 2.05% (172032 bytes) AVI file format detected.
VIDEO: [XVID] 720x480 24bpp 25.000 fps 1125.2 kbps (137.4 kbyte/s)
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x20), ratio: 24000->176400 (192.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[gl] Using 4 as slice height (0 means image height).
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, big endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Big-Endian)
ao_sgi, init: Samplerate: 44100Hz Channels: Stereo Format Signed 16-bit (Big-Endian)
AO: [sgi] 44100Hz 2ch Signed 16-bit (Big-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Starting playback...
[mpeg4 @ 106a56a8]looks like this file was encoded with (divx4/(old)xvid/opendivx) -> forcing low_delay flag
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
No accelerated colorspace conversion found
SwScaler: using unscaled Planar YV12 -> RGB 32-bit special converter
VO: [gl] 720x480 => 720x480 RGB 32-bit [zoom]
XIO: fatal IO error 131 (Connection reset by peer) on X server ":0.0"90%
after 67 requests (67 known processed) with 0 events remaining.

BTW what does the -f switch do and what does the -ao switch do. Sorry but I don't seem to have any documentation and I don't know how to install the man pages(if it exists).

Cheers
barefoot
yup, known problem.. it was mentioned in the other mplayer thread as well. Some (mostly high res/high bitrate) files don't display on mgras with 4MB tram.. vo_gl2 only gives a still image, vo_gl only a blank window iirc. I didn't look deeper into this one but I supposed it was a texture size issue too.. given that it only appears with quite heavy files and odyssey and o2 don't show this behavior. Sorry to be not of much help here

barefoot wrote: BTW what does the -f switch do and what does the -ao switch do. Sorry but I don't seem to have any documentation and I don't know how to install the man pages(if it exists).

-f is non existant -ao selects the audio output plugin. The manpages are included but as I chose to install to /opt/mplayer they are not in your $MANPATH. So include /opt/mplayer/man in your $MANPATH or read it with man -M /opt/mplayer/man mplayer

so long,
Timo
With -ao you specify the audio output driver and/or device. See -ao help for a list of available drivers; -vo does the same, for video. I recommend you to view the manpage as schleusel described because the available options are _huge_.

-f doesn't exist if you want f ull s creen try the option -fs.
$ cat TODO
Learn Inner Sanctuary; Act Autonomous; Forge Future; Experience Enthean Enlightenment.
schleusel wrote: yup, known problem.. it was mentioned in the other mplayer thread as well. Some (mostly high res/high bitrate) files don't display on mgras with 4MB tram.. vo_gl2 only gives a still image, vo_gl only a blank window iirc. I didn't look deeper into this one but I supposed it was a texture size issue too.. given that it only appears with quite heavy files and odyssey and o2 don't show this behavior. Sorry to be not of much help here

barefoot wrote: BTW what does the -f switch do and what does the -ao switch do. Sorry but I don't seem to have any documentation and I don't know how to install the man pages(if it exists).

-f is non existant -ao selects the audio output plugin. The manpages are included but as I chose to install to /opt/mplayer they are not in your $MANPATH. So include /opt/mplayer/man in your $MANPATH or read it with man -M /opt/mplayer/man mplayer

so long,
Timo


Timo,

Thanks, much reading ahead :-) , is the location of man pages defined at startup somewhere? (so I can just add /opt/mplayer/man to it)

Thanks also for your port of mplayer, great job!
please, tell me that my Octane2 400 MHz 1 GB RAM V6 can use mplayer rightly :shock:
We are here on Earth to do good to others. What the others are here for, I don't know.
barefoot wrote: Thanks, much reading ahead :-) , is the location of man pages defined at startup somewhere? (so I can just add /opt/mplayer/man to it)


you can set it in your ~/.login for example. Likely there is already a line defining the $MANPATH. Just add :/opt/mplayer/man at the end of it. If there is no such line just add one:
setenv MANPATH ${MANPATH}:/opt/mplayer/man

themacosxflies wrote: please, tell me that my Octane2 400 MHz 1 GB RAM V6 can use mplayer rightly


sure, no problem. Thats the config I was running until recently (dual 300 instead now).. mplayer was fun on it for almost anything I tried. Above problem doesn't exist on the V6..

so long,
Timo
ok. after MUCH tribulation (don't even get me started) i have my MXI in and working great.

i am using:

Code: Select all

mplayer -vo gl2 -ao sgi -vf format=rgb24 -fs filename.avi


on an xvid @ 640x352

it's a bit stuttery at first (like < 20 secs) as it fills its cache, then it is flawless

at least, so far - i haven't watched a long vid to see if it goes outta sync. tho fast forwarding into the file works fine.

i am incredibly happy.
ubi dubium ibi libertas
In case anyone else is interested, I've experimented with various resolution and bit rate, with a dual R12k 300 MXE 2Gb Ram and R10K drive setup I get the following optimal resolution:

672x378 with a bit rate of 3612kb/s - gl2
720x480 " " - X11

I have an mpg of gr_osview running on the second head (gl2 playback) and can put it up if anyone is interested (2.5MB). It shows mplayer using one CPU only most of the time and it is really maxed out. It also shows the gfx load is never more than 40% (which is good to know, and confirms that amount of trams being the only limitation to higher res. playback).

Cheers
barefoot