SGI: Video

video format help needed !

Hi all,

Can anyone help me to compile video format 1920x1200_50 or 60 for Onyx2 IR2 to use it with Fujitsu-Siemens P26W-5 IPS monitor ( specs - ... 5_eco.html ) ? I have tried to do it myself, but with no luck - format loads and screen starts going blank every 2 or 3 seconds. I'v made 1920x1080_59.95 - works great, but would like to use full potential of monitor :)

Thank you in advance !

I thought on all the Onyx you can use ircombine for set up video.
Yes, thats correct ! I used ircombine to make .cmb but the problem is that video format ( .vof ) wich i made are not working correctly :(
could you post the source file of the working vof?

i'v used mgras-Blocksync for creating vof files, don't have any sources :(
ircombine includes a combination file that will load 1920x1200_60 your primary graphics channel <channel 0, the other part of the combination loads 1280x1024_60 into graphics channel 1>. Have you tried using that combination file? You'll need to load a combination file - a single vfo written to one channel won't work. If necessary, you can edit the channel attributes <such as sync> to match those of your monitor .

To make proper use of combination files you'll have to write them to the EEPROM in your graphics engine <the ircombine manual uses the term "download" to indicate the process of writing the combination file to the GE EEPROM>.

Chapter 2 of the InfiniteReality Video Format Combiner User's Guide gives an example of the "download" process: ... ml#id66871

If you back yourself into a corner with a resolution that won't display on your monitor, you can reload the factory default <1280x1024_60> into the EEPROM using the "-c" switch with the InfiniteReality EEPROM tool: ... M_Commands

Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *

original 1920x1200_60 does not work - screen goes blank every 2 or 3 seconds. for me it looks like it's loosing signal all the time. i'v played with sync settings - no luck. to load new combination i'm using /usr/gfx/setmon -w either from terminal window or from remote machine via telnet with enviroment variable set to DISPLAY=:0:0. i think monitor does not like 60 hz ! 1920x1080 also didn't work at 60 so i managed to make working 1920x1080_59.95.
I'm probably asking the obvious, but did you download/write the 1920x1200_60. cmb to the EEPROM and then restart gfx or reboot <rather than 1920x1200_60.vfo>? Because IR graphics are muli-channel, they require a combination file - loading a single/uncombined vfo file isn't supported. If you haven't, try I'd suggest doing so with ircombine, rather than setmon. If you're stuck at the command line and find setmon's syntax a little more user friendly, you can write the cmb file to the EEPROM with setmon via the -x or -w command line switches, but I'd still suggest you reinitialize graphics.

The setmon man page gives a brief description of the reasoning for using combination files:
man setmon wrote:
Infinite Reality Graphics
    always operates as a multiple-channel device, and a simple
    video format for a single channel is insufficient to describe
    the operation of the entire video subsystem. Instead of simple
    video formats, only video format combinations are supported.
    On Infinite Reality, setmon requires a combination file - a
    file describing frame buffer layout and formats for all
    channels - as the format parameter. These combination files
    can be built with a program, ircombine(1g), that assembles an
    ensemble of formats. The individual formats used by
    ircombine(1g) reside in /usr/gfx/ucode/KONA/dg4/vfo, and are
    described in /usr/gfx/ucode/KONA/dg4/vfo/README.

    A number of pre-built combinations can be found in the
    directory /usr/gfx/ucode/KONA/dg4/cmb. The names of these
    files are sometimes precisely descriptive of their content, but
    you can use ircombine(1G) to extract a full analysis of any
    combination. Note that if you create new combinations of your
    own, you must place them in /usr/gfx/ucode/KONA/dg4/cmb before
    they can be loaded with setmon.

    For backward compatibility, setmon supports a set of pre-built
    combinations that contain only one format each. These
    combinations are named similarly to the corresponding formats
    on Reality Engine.
If you'd like to try to build your own vfo file, the readme file located in /usr/gfx/ucode/KONA/dg4/vfo gives specifics of the parameters used to build each of the pre-existing graphics modes. There's a DG4 definition file in /usr/gfx/ucode/vfc/rules/dg4.def for use with the video format compiler that might work better for you than the MGRAS block sync.

If you're working from a command line, ircombine can be run from there as well <see "man ircombine">. I've successfully used the ircombine GUI to load and display that same sample 1920x1200_60.cmb on a <different> 24" LCD.

Although they might not be the optimal resolution, it looks like your monitor does support other display modes. 1600x1200, 1024x768 and even 800x600, but interestingly *not* 1280x1024. You might try a few of those to see if your monitor will accept them <and it would allow you to work in the ircombine GUI>. You could also try the 1920x1200_66 combination file to see if your monitor will accept that.

Other than that, you just might have a monitor that isn't compatible.

Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *
yes - i loaded .cmb file not .vfo :

/usr/gfx/setemon -w 1920x1200_60

strange, but i don't have such format as 1920x1200_66 ! not in a cmb or vfo. could you please send it to me ?
from monitor specs it says that monitor supports frequency up to 85 hz. if i load combination with resolution lower then 1920x1080 i get a message on monitor - "optimal resolution is 1920x1200 60 hz".
valdis.liseks wrote:
strange, but i don't have such format as 1920x1200_66 ! not in a cmb or vfo. could you please send it to me ?
Then it's probably one I made.

Welcome to ARMLand - 0/0x0d00
running...(sherwood-root 0607201829)
* InfiniteReality/Reality Software, IRIX 6.5 Release *
bad news - 1920x1200_66.cmb does not work. looks like the only option is to use 1920x1080. anyway - thank you recondas for help !

best regards,