IRIX and Software

sgi's 'gnu' package

Hey all.

Forgive me if this is answered somewhere on the forums... but I searched and couldn't find anything relevant (actually was overwhelmed with the hits I got). I've got my desktop system running 6.5.27, and I wanted to install the 'gnu' package.

I've got all the base 6.5 cd's and the different overlays on disk... so when I go into inst I can load up easily all cd's needed. I then load up the following packages (what I always do... except the overlays change depending on what 6.5.x version I"m working on):


I know I want only the 'gnu' package... so I then type 'keep *' and then 'install gnu'. When I then look to see what I installed, I of course see all the 'gnu' subproducts listed that come out of the 6.5.27_Applications cdrom like I expected.

But when I check for conflicts, I see a bunch (like thirty of them) of these:

gnu.sw.textutils cannot be installed because of missing prerequisites:
1a. Do not install gnu.sw.textutils (1278600920)
1b. Also install fw_textutils.sw.textutils (1236376120 - 1289999900) from
an additional distribution -- insert another CD or specify another
software distribution.

gnu.sw.tar cannot be installed because of missing prerequisites:
2a. Do not install gnu.sw.tar (1278600920)
2b. Also install fw_tar.sw.tar (1278555120 - 1289999900) from an
additional distribution -- insert another CD or specify another
software distribution.

I know that in earlier distributions there were actually 'freeware' cdroms... I've got three freeware cd's (1 of 3... 2 of 3... 3 of 3) from May 200, but I don't think they do that anymore since I haven't seen the cd's in a long time.

Now if I know exactly what cd's that inst is looking for... and I've never understood what the numbers in parenthesis are.

So I'd love it if somebody could enlighten me on what I'm missing. Thanks!

in this case i would just ignore the deps.
I thought about ingoring the dependencies... but correct me if I'm wrong but I can't do that unless I type 'set rulesoverride on' to let it install anyway. Then of course there's still no way of knowing what kind of unknowns doing this could cause.

I was kinda hoping somebody else out on the board has seen/solved this. :)
Ok... tried two things. First, I loaded up the freeware cdrom's I have to disk to see if they could be the magic cd's to resolve my conflicts. No go.

I then figured what the heck... when I had my conflicts that I showed, I 'set rulesoverride on' and told it to install. I've done this before with no issues... but this time was different. I got this upon quitting out of inst:

Inst> quit

The software installed on this system has existing conflicts.
Exit allowed because "rulesoverride" option is set.

And then from 'versions long' I can see that the subproducts have no file size:

l 0 0 gnu.sw.emacs usr/gnu/bin/b2m
l 0 0 gnu.sw.shutils usr/gnu/bin/basename
l 0 0 gnu.sw.bash usr/gnu/bin/bash
l 0 0 gnu.sw.textutils usr/gnu/bin/cat

and also when I cd to /usr/gnu/bin where the binaries should be, all the newly installed files are dangling symbolic links to /usr/freeware/bin.

So I'm officially out of options... any thoughts from anybody?

well, looks to me as if that 'gnu' package relies on the freeware tardists available from to work its magic. it seems that the right subsystems are not on those freeware cds of yours or in the wrong version. why not solve the conflicts by downloading and installing the packages it wants? and while you're at it, look at nekoware, we got all them tools compiled too, and much more bleeding edge than the freeware ones, especially if you're running .22 or higher. (blatent nekoware ad)