IRIX and Software

rsync problems


I just recently aquired my first SGI system, an O2:

IRIS 1# hinv
CPU: MIPS R10000 Processor Chip Revision: 3.4
FPU: MIPS R10010 Floating Point Chip Revision: 0.0
1 250 MHZ IP32 Processor
Main memory size: 256 Mbytes
Secondary unified instruction/data cache size: 1 Mbyte on Processor 0
Instruction cache size: 32 Kbytes
Data cache size: 32 Kbytes
FLASH PROM version 4.18
Integral SCSI controller 0: Version ADAPTEC 7880
Disk drive: unit 2 on SCSI controller 0
CDROM: unit 4 on SCSI controller 0
Integral SCSI controller 1: Version ADAPTEC 7880
On-board serial ports: tty1
On-board serial ports: tty2
On-board EPP/ECP parallel port
CRM graphics installed
Integral Ethernet: ec0, version 1
Iris Audio Processor: version A3 revision 0
Video: MVP unit 0 version 1.4
AV: AV1 Card version 1, Camera not connected.
Vice: TRE
1600SW Flat Panel adapter board and display.

As this is my first system I am a complete novice with IRIX. Therefore, I apologize if my questions are silly but I have been doing my best to learn how this system works. One of the many hurdles I have come across is attempting to acquire the nekoware files via rsync.

Here is what happens:

IRIS 1# /usr/nekoware/bin/rsync -az --progress \ /usr/nekoware
building file list ...
rsync: link_stat "/" failed: No such file or directory (2)
0 files to consider

sent 29 bytes received 20 bytes 98.00 bytes/sec
total size is 0 speedup is 0.00
rsync error: some files could not be transferred (code 23) at main.c(892) [sender=2.6.8]

I do not understand why it cannot connect when there is no issue with the mirror.

Thank you for any help!

Image with MLA
Image O2 R10k 250Mhz, 256MB RAM, 140GB HD, 1600SW board, IRIX 6.5.30
Hi I have no idea about anything SGI or IRIX but this looks wrong. One I think you're supposed to use something like


while you have


The message you get suggests it's looking on your local system for / and that would explain it.

On the remote chance this might help...because I am almost always wrong about anything UNIX-related but since nobody answered yet I tried anyway. What bravery! ;-)

Paint It Blue
Welcome to Nekochan, LgnLndstrm!

bluecode: Thanks for stepping up, that's what immediately stood out to me as well.

LgnLndstrm: If removing that extra colon doesn't work, have you made some basic connectivity checks - can you ping from the O2 ? Can you reach Yahoo with Netscape/Mozilla? I see you already have nekoware's rsync installed, but did you download it with another machine, then transferred it to your O2? Or did you download it directly to the O2?

Then? :IRIS3130: ... Now? :O3x02L: :A3504L: - :A3502L: :1600SW: +MLA :Fuel: :Octane2: :Octane: :Indigo2IMP: ... Other: DEC :BA213: :BA123: Sun , DG AViiON , NeXT :Cube:
Bluecode and smj, thank you for your responses. After playing around a little the following ended up working:

/usr/nekoware/bin/rsync -az --progress \ /usr/nekoware

The files are currently downloading!

Hopefully this post can help anyone else trying to get nekoware on their system.

On the nekoware page it has "" as the option for rsync; however, this evidently does not work. I ended up using a different mirror as shown above.

Image with MLA
Image O2 R10k 250Mhz, 256MB RAM, 140GB HD, 1600SW board, IRIX 6.5.30
Glad you got it working. Another satisfied forum customer :P

smj, good eyeball on my post. Actually I left out the extra colon just from habit. I use rsync a lot. What was critical was the placement of the slash character. It has to come after the colon(s). In his example he had it before and I think that led to the shell expanding it to a local path that didn't exist. That was the error message. Nothing to do with the extra ":" afaik.

The format for scp and rsync is something like

sendingpath hostname:/receivingpath


sendinghostname:/path /receivingpath

I never used the :: but it does mean something according to the rsync man page.

Bluecode, Batting 1/10,000 on UNIX issues and emboldened greatly by an elusive and unexpected tiny measure of success, however ephemeral or insignificant it may well have been. :lol:

Paint It Blue