Getting Started, Documentation, Tips & Tricks

networking dumb move

If we had a "dimbulb screws up" category I could populate it all by myself ..

Two IP 35 machines, both Irix 6.5.30. Both were running fine, shared objects showed up in either direction, worked fine.

I musta did something bad.
Suddenly networking works fine in one direction.

In the other direction, the remote host icon shows on the desktop. Double-clicking shows its shared objects. Double-clicking the shared directory icon returns an error code < Unable to locate ". The path does not exist.> Both from a terminal and graphically, nothing shows up in /hosts Same situation is true for all users including root.

Fired up george, the IBM x86 vortex of trepidation. Twenty minutes later it was done booting (Solaris). Same result. Everything works fine everywhere except this one host. Pinging works fine from everyone to everyone.

What's the dumbest thing I could have done ? Most likely that's it.
Is NFS running? Try telnetting in on the NFS port. Run TCPdump or other sniffer and see what's going on (both client and server). Can you get in on other allowed services?

What auth are you using, and is it working properly?

Damn the torpedoes, full speed ahead!

:Indigo: :Octane: :Indigo2: :Indigo2IMP: :Indy: :PI: :O200: :ChallengeL:
Just in case someone else has this problem ...after a lot of hassling I found that I could manually mount remote resources. I could also mount remote resources using the gui. But if I tried to do it the easy way, from the toolchest -> desktop -> shared resources, no dice. The /hosts directory was there, I messed with that a bit thinking its permissions got butchered somehow but that didn't help. Autofs was chkconfigged on but I redid all that anyway. Still no dice. Looked under man autofs (when all else fails rtfm) and it mentioned the mount point for autofs'ed file systems. And the error message was "no path to ." Looked carefully, the file /etc/auto_master had somehow gone missing. I dunno, I didn't do nuthin ! I was just kinda walkin' thru, not runnin' or nuthin, just walkin' real slow and careful and that lamp ? you know that lamp ? the one grandma gave you for christmas ? It just fell over all by itself. Maybe there was a earthquake ?

Anyhoo, if you use the autofs method of mounting remote resources and it quits working suddenly, check for a file /etc/auto_master which tells the system where to mount remote directories. No wonder it couldn't find "." It didn't know where to look.