Miscellaneous Operating Systems/Hardware

Error: Depency not satisfiable: libc6

After finally realizing that it was possible to run limewire off ubuntu I set out to download it and the required version of java. After about an hour of work (after about another hour of downloading from the extremely slow server which holds ubuntu's software) I finally got stumped on this error when I tried to use Package installer:
Code:
Error: Depency not satisfiable: libc6


I looked over it all and to my luck the dependancy tree is the most mysterious linux component when it comes to my little linux-newb mind. What's the missing factor and what can be done to fix it?

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.
You pretty much need libc6 to do anything, so my guess is its a version issue. Ubuntu is actually very bad about this, frequently updating their libc. I'm on Debian Etch and can't use packages compiled for newer Ubuntu setups because it was compiled against a slightly newer libc. To see what version you have use dpkg -l

Code:
[email protected]$ dpkg -l libc6
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                         Version                      Description
+++-============================-============================-========================================================================
ii  libc6                        2.3.6.ds1-13                 GNU C Library: Shared libraries


Then check the libc needed by the package. An apt-get update, apt-get libc6 might just update the package, but I'd apt-get dist-upgrade to make sure you don't cause any more dependency problems (libc should be backwards binary compatible, but sometime isn't).

Finally, assuming your connection isn't to blame, might I suggest using a different mirror in /etc/apt/sources.list? I'm sure you can find a list of mirrors on the Ubuntu website.

Hope this helps.
Code:
[email protected]:/home/pentium# dpkg -l libc6
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  libc6          2.3.6-0ubuntu2 GNU C Library: Shared libraries and Timezone

^^My system.
There won't be a newer release of ubuntu for a few months and I really don't know if my system would handle it.

As for seing what version of libc6 is needed for limewire, I can't find the requirements anywhere.

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.
I downloaded the latest .deb of limewire and got this error message:

Code:
limewire-basic depends on libc6 (>= 2.4-1); however:
Version of libc6 on system is 2.3.6.ds1-13.


Libc on fiesty is http://packages.ubuntu.com/feisty/base/libc6 (2.5-0)

What version of Ubuntu are you running?
Also, Debian and Ubuntu are not static distributions. Apt-get update, apt-get dist-update will keep your (stable/ testing/ Ubuntu revision) but will update the packages that have changed.

EDIT: Looks like you're using Dapper? If so, you need to upgrade (or at least download the .deb of the newer libc (edgy has 2.4-1, so it should work)) to use that version of limewire.
Remember you can usually run ldd on the (ELF) binary and get an idea of what it needs.

Invaluable when you come across one of those sites who think that "Linux 2.6.14" is a sufficient descriptor of the system requirements :roll: .
yes, tillin I am using ubuntu but I upgraded to 6.10 a few months back.

Your link is also dead.

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.
If you're on 6.10 (Edgy) but have not run apt-get update, apt-get dist-upgrade in awhile, doing so will fix your whole problem as Edgy is should have libc6 2.4-1. Both Debian and Ubuntu routinely compile packages, release them, then upgrade them within a distribution. Doing an apt-get dist-upgrade will not move you to fiesty. It will, however, have a lot of updates if you haven't done this in awhile. An apt-get update, apt-get install libc6 might have fewer packages. However, the bigger point is you should run apt-get update, apt-get dist-upgrade regularly (I script it via cron on my Debian stable servers) to get things like security updates.

As far as the link, it looks like Ubuntu's servers are getting hammered, the whole package search section is down. The google cache: http://64.233.167.104/search?q=cache:dr ... cd=6&gl=us also shows the individual package link is down. Maybe the package mirrors are down too?
pentium wrote:
Your link is also dead.


So what's the difference between

Quote:
ERROR
The requested URL could not be retrieved


and

Quote:
Error: Depency not satisfiable: libc6


:)

I abandoned Ubuntu and returned to Debian for these reasons.

_________________
Land of the Long White Cloud and no Software Patents.
Quote:
I abandoned Ubuntu and returned to Debian for these reasons.

I'm lazy.
I just got settled into ubuntu. I don't want to transition over yet.

EDIT:
Oh, and I use automatic updates.
Doing both apt-get and apt-get dist-upgrade give:
Code:
[email protected]:~$ sudo apt-get update
Password:
Get:1 http://security.ubuntu.com dapper-security Release.gpg [191B]
Hit http://security.ubuntu.com dapper-security Release
Hit http://security.ubuntu.com dapper-security/main Packages
Hit http://security.ubuntu.com dapper-security/restricted Packages
Hit http://security.ubuntu.com dapper-security/main Sources
Hit http://security.ubuntu.com dapper-security/restricted Sources
Hit http://security.ubuntu.com dapper-security/multiverse Packages
Get:2 http://ca.archive.ubuntu.com dapper Release.gpg [189B]
Get:3 http://ca.archive.ubuntu.com dapper-updates Release.gpg [191B]
Hit http://ca.archive.ubuntu.com dapper Release
Hit http://ca.archive.ubuntu.com dapper-updates Release
Hit http://ca.archive.ubuntu.com dapper/main Packages
Hit http://ca.archive.ubuntu.com dapper/restricted Packages
Hit http://ca.archive.ubuntu.com dapper/main Sources
Hit http://ca.archive.ubuntu.com dapper/restricted Sources
Hit http://ca.archive.ubuntu.com dapper/universe Packages
Hit http://ca.archive.ubuntu.com dapper/universe Sources
Hit http://ca.archive.ubuntu.com dapper/multiverse Packages
Hit http://ca.archive.ubuntu.com dapper-updates/main Packages
Hit http://ca.archive.ubuntu.com dapper-updates/restricted Packages
Hit http://ca.archive.ubuntu.com dapper-updates/main Sources
Hit http://ca.archive.ubuntu.com dapper-updates/restricted Sources
Hit http://ca.archive.ubuntu.com dapper-updates/multiverse Packages
Fetched 3B in 5s (1B/s)
Reading package lists... Done
[email protected]:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Running the GTK update manager also finds no new updates at all for anything.

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.
As much as I'm a Debian fan myself (100+ machines running Debian, okay most are work boxes :) ) Debian Etch would have the same problem with Limewire. The Limewire devs used a very new libc. I only have 2.3.6, it needs 2.4-1. The testing (Lenny now), unstable, and experimental are actually all 2.3.6 also. There are some 2.5 libc6 packages in the works, but nothing on the mirrors.

My opinion is to wait for the Ubuntu servers. Using the Debian unstable package: http://packages.debian.org/unstable/libs/libc6 would also be a possibility (I've used Ubuntu packages on Debian before), but I would think twice if this is more than a test box.

EDIT: Yes, so you're on Dapper. You said above you were on Edgy (6.10). Dapper only has an older version of libc6. Sorry if any confusion was on my part.

You might want to swap dapper for edgy in your /etc/apt/sources.list, then run apt-get update, apt-get libc6 and see what other packages it wants to pull along if the Ubuntu mirrors seem to be responding better than their web page.
Quote:
You said above you were on Edgy (6.10)

Doh! My mistake.

Quote:
You might want to swap dapper for edgy in your /etc/apt/sources.list, then run apt-get update, apt-get libc6 and see what other packages it wants to pull along

??? I didn't get what you meant.

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.
Hey, no problem.

I'm on Debian Etch, but your /etc/apt/sources.list should look something like this:

Code:
[email protected]$ more /etc/apt/sources.list
deb http://ftp.debian.org/ etch main contrib non-free
deb http://mirrors.kernel.org/debian/ etch main contrib non-free
deb http://debian.lcs.mit.edu/debian/ etch main contrib non-free

deb http://security.debian.org/ etch/updates main


But with a dapper in there instead of etch as that is your release name. Your mirrors will also be different. Anyway... to change distributions you just substitute the release name in this file. For example if I wanted to move my machine to testing (Lenny) I would swap etch to lenny then run apt-get update. You would swap dapper with edgy. The nice thing about apt, is you don't have to upgrade the whole distribution. If you're on Debian stable, but really want something that's only in testing, you change your /etc/apt/sources.list file, apt-get update, apt-get install packagename (it will automatically install the updated dependencies), then swap it back and run apt-get update. Apt is smart enough to leave those updated packages alone when you run your automatic updates. Granted a mixed distribution is inherently less stable than a pure one, but the vast majority of the time it works. This is essentially the same thing as downloading and manually running dpkg -i on the Dapper or Fiesty libc6 package but allows you to get the package through the Ubuntu mirrors since the http site seems to be down.
So what yor are saying is that if I change...

Code:
deb http://ca.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://ca.archive.ubuntu.com/ubuntu/ dapper main restricted
deb http://ca.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://ca.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb http://ca.archive.ubuntu.com/ubuntu/ dapper universe
deb-src http://ca.archive.ubuntu.com/ubuntu/ dapper universe
deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted


...to the locations for edgy packages and then run update manager, I will upgrade the system to edgy?

_________________
:Crimson: :Onyx: :O2000: :O200: :O200: :PI: :Indigo: :Indigo: :Indigo: :Octane: :O2: :1600SW: :Indigo2: :Indigo2: :Indigo2IMP: :Indigo2IMP: :Indy: :Indy: :Indy: :Cube:

Image <-------- A very happy forum member.
tillin9 wrote:
The Limewire devs used a very new libc. I only have 2.3.6, it needs 2.4-1. The testing (Lenny now), unstable, and experimental are actually all 2.3.6 also. There are some 2.5 libc6 packages in the works, but nothing on the mirrors.


*ahem*...

Code:
[[email protected] ~]$ cat /etc/debian_version
lenny/sid
[[email protected] ~]$ dpkg -l libc6
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                    Version                 Description
+++-=======================-=======================-==============================================================
ii  libc6                   2.5-7                   GNU C Library: Shared libraries



:)

The main point still stands though. Stable releases do not upgrade versions. If you have a stable ubuntu you'll never see newer versions trickle in - only bugfixes to existing versions. If you want to keep up with the merry-go-round, you have to hop on and use a testing distribution... :)

_________________
while (!asleep()) sheep++;
pentium wrote:
So what your are saying is that if I change the locations for edgy packages and then run update manager, I will upgrade the system to edgy?

Yes. If you were to change those to edgy, the run a full apt-get update, apt-get dist-upgrade you would update everything to edgy. However, if you just apt-get install libc6 you'll only upgrade libc6 and dependencies to the edgy versions. I'm not sure how good Ubuntu is about going from one whole release to another. I remember I had one of my home machines set to stable (instead of Woody, rather stupidly) and when Sarge became stable instead of Woody the automatic updates migrated the machines over to Sarge (since Sarge was now stable) without a single issue.

As far as libc-2.6-7 not being on the mirrors, these things are not static and when I wrote that it wasn't. My comment still stands that the Limewire devs probably shouldn't have used such a new version when a lot of users don't have it. Using a testing version where things break isn't necessarily the best solution.