XVR-100 DVI console

First off, I know Sun didn't initially support DVI console out on these cards. You have to upgrade the initial firmware to version 1.61 (which I mentioned in my other thread about making an XVR-100 out of a Mac Radeon 7k).

I _know_ the XVR-100 supports DVI console out because that's how I have it set up on my SPARCEngine. The problem is that I don't remember how I did it :D

I took a look @ the output of devalias on the old machine and screen is setup to point to something like this:
/[email protected],700000/SUNW,[email protected] (@1 is the analog video output. I'm guessing @2 is the unsupported S-Video output).

On the SB 1000 I set up a new devalias called "dviconsole" that points to @3. I then set "output-device" to the new devalias.

That gives me output on DVI but only after the X Server starts. The monitor acknowledges it's getting a signal of some sort before then but the screen stays black.

Anyone else have an XVR-100 (Sun or otherwise) and had any success with this? Well, besides forgetful old me :D
You can take the following steps at OpenBoot PROM to designate a framebuffer as a console:

OK show-displays
Select the graphics accelerator, e.g. b

OK nvalias mydev <CTRL-Y>
OK setenv output-device mydev
OK setenv use-nvramrc? true
OK reset-all
With the exception of the "reset-all" command that's pretty much what I did.

I also tried setting the resolution in the "output-device" NVRAM variable
(i.e. output-device=dviconsole:r1280x1024x60).
So months later I'm using the 'blade and I tried again. Here's what worked for me (you'll probably have to change the device as appropriate:

Code: Select all

eeprom "nvramrc=devalias dviconsole /[email protected],700000/SUNW,[email protected]:pfb0"
eeprom "output-device"=dviconsole:r1280x1024x60
Just to add a further bit of info - I recently tried to set up an Ultra 5 with a XVR-100 running at 1920x1200 using the DVI connection. After a lot of frustration and monitor swapping I came to the conclusion (which was backed up by a friend looking into what was *officially* support) that this resolution is not supported. I suspect if my monitor could handle 1920x1200x70 or x75 it *might* have worked.

I haven't had any issues configuring it to work at 1920x1080x60 however. The 1920x1200 monitor would work using the VGA connection but I tried several cables and the picture wasnt *quite* perfect (not far off mind, and the quality did improve with better cables). I'm suspecting that 1920x1200 is really stretching the VGA bandwidth.

I set the X display specifically to the pfb0b device so that it would be brought up in DVI mode.

(this was done by editing /usr/dt/config/Xservers and adding -dev /dev/fbs/pfb0b to the end of the :0 directive.

Regards, Mark.
Image , VAXstation 4000/90 x2, VAXstation 4000/VLC x2, AlphaServer 1000A, DEC AXP 3000/600 (desktop), DEC AXP 3000/600 x2 (rackmount), DEC AXP 3000/800 (rackmount), AlphaServer 300 4/266, Sun Ultra 5, LA75, PP404, Juki 6100, Brother HR10